新建网页 1

迷你型 TL866 通用编程器-->性能介绍

精心打造的廉价的专业型编程器， 高密度贴片工艺制作，统一的操作界面，使用方便，功能完整，应用软件程序运行可靠，代码超小，执行速度更快，支持中英双语。可运行的操作系统：
WINDOWS 2000 WINDOWS XP
WINDOWS 2003 WINDOWS 2008
WINDOWS VISTA WIN7(32bits and 64bits)
 能自动识别操作系统安装及运行。(在WIN7 64位操作系统安装时，必须以管理员身份运行EXE安装包.)
 注：下列性能列表★是极大部分开发型编程器无法比的，也是比较不容易做到的功能。

★高速编程：内置高性能，大容量USB接口单片机，通讯速率12Mbps,配合（ 针对每个芯片）精心设计的编程算法及USB高速的通讯。可能是综合开发型编程器中最快的一个，该速度已经符合小批量快速生产的需要。
相比同类产品有的芯片编程速度快上几倍，甚至10倍以上，4Mbits的并行FLASH ROM，经升级到3.01版本以上编程器编程（擦除、写、校验总时间）只需35秒左右，读写一片32MB TE28F320只需32+79秒，并且极大部分并行FLASH芯片编程时同时校验，发现错误能即刻终止编程 ，读写一片8Mbits的串行 25P80只需12秒（读）+18秒（写）时间。64MB容量的芯片最快只需98秒+160秒。支持常见8PIN和16PIN封装的大容量25系列芯片。
 注：16MB以上大容量FLASH芯片因为编程器速度的原因，一般编程器已无法完成，本编程器全面支持到 64MB 串并行系列芯片。特显高性能品质！
---详细查看:常用芯片的编程实测速度列表

◆宽范围的芯片支持: 各种26 27 28 29 37 39 49 50系列并行ROM、EPROM、EEPROM，24 25 35 85 93 95系列串行EEPROM，串并行ROM系列芯片容量全面支持到48PIN的64MBITS.多种型号的51系列单片机，AVR单片机，包括ATMEGA系列 ATtiny系列 AT90XXX系列单片机 ，MICROCHIP PIC10 PIC12 PIC16 PIC18系列单片机，GAL可编程逻辑器件编程，SRAM测试，54/74及CMOS4000系列集成电路综合功能测试. 现在实际可编程芯片 已超过 12 000（V5.50版软件）.升级过程中将不断增加对更多芯片的支持。
---查看:点击查看芯片支持范围

★独一无二的超低功耗：整个编程器全部采用超低功耗芯片，采用USB接口供电，第一台真正做到所有芯片编程不用外接电源的综合编程器。 实测自身耗电小于20mA，（不编程时是7mA，最大耗电是LED电源指示灯每个5mA)，编程时功率损耗率小于20%。使编程器能通过USB接口提供超强的VCC VPP编程电流。对所有的可编程芯片能提供足够的编程功率（最大可达2瓦编程功率输出，不可能有芯片需要2瓦的功率编程）。并且既使编程器长时间连续编程芯片，你也几乎感觉不到编程器有热量。

★便携性能超强：体积全球最小的一个，外型尺寸 10CM*6CM*2.5CM，只有驾驶证大小。另外由于超低功耗，从而真正免除了外接电源，使便携性能超强。

◆程控的编程电源: VPP 和VCC编程电压都独立程控，可编程VCC从3.3V到6.5V，VPP从3.3V到21V供电的芯片。 电源经多级LC滤波，波 纹极小。

★最佳的过压、过流保护: 编程器VCC VPP电源内部有独立的3级过流保护，另加一级软件自动切断供电保护。对每个40P编程插座引脚都有VPP过压保护。有效防止插错芯片或其他原因引起的外部引脚短路，编程时，VPP高压窜回到编程器内部而损坏编程器。真正做到外部发生任何最坏情况的短路，不会损坏编程器，并且最有效的保护被编程的芯片。
 发生短时，本编程器定时100us切断编程电源VPP及VCC，并发送信息给应用程序，由于采用了多级过流保护，短路时绝不会引起编程器及PC复位。

◆40PIN 万能引脚: 40PIN 准万能引脚中，最万能的一个。做到了所有芯片编程时放置，无一芯片需要移位或转向放置，芯片统一向前、编程插座手柄方向为PIN1放置，更符合设计人员的操作习惯。

◆升级功能: 内置硬件固化程序的升级功能，可保证你的编程器固件FLASH及应用软件的更新。升级通过互联网下载升级程序，自行升级。

★芯片序列号二次开发功能：编程器内置了常用的多种自动编号功能。 并可使用自定义算法，通过DLL动态库实现任意的序列号。该功能可以使你在批量生产时，每个芯片都产生一个唯一的标识信息。通过自定义算法还可对该标识进行加密，从而更有效保护你的产品权益。查看：设置芯片编号

★独特的万能串行编程接口ICSP：（仅TL866A支持，TL866CS限止使用该功能）
 通过40PIN万能插座编程的同时，本编程器还带一个ICSP串行编程口。对可进行在线串行编程的芯片，你可选择ICSP接口对在目标板上的MCU进行编程，ICSP口的接线法，程序内带高清 晰图片提示。从而方便对已焊在板上的芯片进行更新编程。
注：ICSP现支持ATMEL89S51、52，AT45DBxxx、AVR ATMEGAxxx全系列及MICROCHIP PIC10Fxxx 12Fxxx 16Fxxx 18Fxxx全系列，及新茂SYNCMOS SM59Dxx SM59Rxx全系列芯片进行在线串行编程。将来会增加其他更多支持串行在线编程的单片机。本编程器的ICSP的6条线，除一条地线GND，其他线引出了全功能的I2C、SPI及UART串行总线，适合各种串行通讯。并且每条线可给超强电流的VCC、VPP或GND。

★性能超强的54/74F/LS/HC CMOS4000系列集成电路综合功能测试：真正可测试常见逻辑集成电路的第一个开发型编程器，测试可定位到逻辑门电路的错误，测试集成电路的任意可能出现的输入组合。

◆编程器自检功能：编程器可对各个引脚的VPP VDD GND及输入输出 等信号进行自检，并对VPP、VCC过流进行内部实际短路（同时向一个PIN引脚加上VPP VCC 及GND进行强电流短路）自检操作。

★AVR单片机一对一软加密：AVR单片机有一个RC Calibration(校正字节)，这个字节值几十个芯片才有一个可能相同，并且无法修改。单片机软件可读出该值，判断这个值就可确定该代码是否被使用到另一个芯片上，通过自定义的加密算法可使暴力破解者无法直接使用。 如果加密算法足够复杂，想信要破解也不是容易的了。但“加密”对开发人员提出了一个问题，每个芯片不同，如果算法复杂不可能一个个去人工计算分别编译原代码。本编程器能在编程前自动读入RC字节，开发人员可在DLL动态函数中得到芯片该字节的值，然后跟据该值按你的要求自动计算加密数据放入存储器中，完成快速量产。（安装包中有个关于ATMEGA8详细加密实例，可供参考）

★统一方便的操作界面：操作界面经精心打造，完全附合Windows系列软件的操作习惯，内置的二进制编辑器，可媲美专业的纯编辑软件。 可对直接对BIN文件、HEX文件、JED等格式文件进行读写修改操作。另有完整实用的工程模式，使批量生产更方便安全。

查看：软件用户界面

相关主题：

快速操作指南

完全操作指南
http://www.autoelectric.cn 中国 海南
TEL：0898 68681816 FAX：0898-68681815 Mobile:13198907988
海口鑫工电子有限公司 Copyright @2009


迷你型 TL866 通用编程器-->芯片支持范围

◆各种26 27 28 29 37 39 49 50系列并行ROM、EPROM、EEPROM

速度快，支持全面。
同时支持TSOP32 TSOP40 TSOP48的芯片到 64MBits，极大部分芯片编程速度是同类编程器的5-10倍速。

◆24 25 35 45 85 93 95系列串行EEPROM

串行系列芯片支持全面，支持芯片容量25系列8 16PIN 到128MBits（16M字节）

◆上百个种型号的51系列单片机

◆AVR单片机，包刮ATMEGA系列 ATtiny系列 AT90XXX系列单片机

支持AVR单片机用RC校正字节进行一对一软加密。
支持高速并行编程，所有的AVR ATMEGAxxx芯片同时支持用ICSP接口进行SPI串行下载编程。
支持TQFP64 TQFP100PIN的AMEGAxxx芯片，

◆MICROCHIP PIC10 PIC12 PIC16 PIC18系列单片机：
PIC系列300多个型号，900个封装以上的芯片支持，目前支持PIC芯片最全的综合编程器之一。对各种型号的PIC单片，严格按厂家手册要求，进行最优化的编程，编程速度优秀。极大部分芯片同时支持ISCP在线编程及通过编程插座进行编程。

◆GAL可编程逻辑器件编程
 支持常见的PLD器件。

◆SRAM测试
 支持常见24 61 62 DS12系列SRAM测试，分别可以以数据线测试、地址线测试、内存单元增量测试及单元测试。

◆性能超强的54/74F/LS/HC CMOS4000系列集成电路综合功能测试：
真正可测试常见逻辑集成电路的第一个开发型编程器，测试可定位到逻辑门电路的错误，测试时，测试集成电路的任意可能出现的输入组合。

可编程芯片12000+，升级过程中将增加更多的芯片支持。

可编程芯片详细列表网址：http://www.autoelectric.cn/minipro

相关主题：


迷你型 TL866 通用编程器-->常见芯片编程速率列表

本编程器列出了常用芯片编程时所实际测试耗费的时间，这些芯片并不是有意挑出来的芯片，同类芯片只要参考表中同类芯片的时间就可，容量不同的同类芯片时间基本上和容量成正比。本编程器是最快的综合型编程之一，相比同类产品有的芯片编程速度快上几倍，甚至10倍以上，4Mbits的并行FLASH ROM，本编程器编程（擦除、写、校验总时间）只需36秒，读写一片32MB TE28F320只需32+79秒，并且极大部分并行FLASH芯片编程时同时校验，发现错误能即刻终止编程 ，读写一片8Mbits的串行 25P80只需12秒（读）+18秒（写）时间。64MB容量的芯片只需98秒+160秒。支持常见8PIN和16PIN封装的大容量25系列芯片。仔细比较其他同类编程器，你会发现本编程器有着无有伦比的速度性能。
 注：16MB以上大容量FLASH芯片因为编程器速度的原因，一般编程器已无法完成，本编程器全面支持到64MB的25.28.29系列 到48PIN的芯片。特显高性能品质！

总时间=擦除时间+编程时间+校验时间
本编程器严格按厂家要求编程，绝不为了提升编程速度而牺牲编程的可靠性。

常见ROM芯片的编程时间：（单位：秒）

芯片类别

芯片型号

容量

擦除时间

读取/校验

写时间

总时间

备注

27Cxxx

27C512 512Kbits / 2S 20.8S 22.8S 28PIN
27C010 1Mbits / 4S 34.2S 38.2S 32PIN
27C1024 16位 1Mbits / 4.1S 19.6S 23.7S 40PIN

电擦除27Cxxx

W27E257 256Kbits 0.1S 1S 10.4S 11.5S 28PIN
SST27SF512 | 512kbits | 0.1S | 1.4S | 20S | 21.5S | 28PIN
W27C010 | 1Mbits | 0.2S | 2.3S | 33.4S | 35.9S | 32PIN

FLASH EEROM

N28F020 2Mbits 0.6S 3.1 10.7 14.4S 32PIN
AT29C020 | 2Mbits | 0.2S | 3.1 | 10.9 | 14.2S
W29C020 | 2Mbits | 0.3S | 3.1 | 11S | 14.3
AM29F040 | 4Mbits | 7.9S | 9.2S | 26 | 43.1S
M29F002 | 2Mbits | 2.5S | 4.6S | 19.5S | 25.6S
SST39SF020 | 2Mbits | 0.4S | 3.6S | 15.6S | 19.6S
AT49F002 | 2Mbits | 1.2S | 3.6S | 16.4S | 11.2S
W39V040AP | 4Mbits | 0.1S | 9.2S | 27S | 36S
M50FW040 | 4Mbits | 7S | 9.2S | 25 | 41.2
INTEL82802AB | 4Mbits | 4S | 9.2S | 25S | 38
AM29F200 | 2Mbits | 3.7 | 2.0 | 8.6 | 14.3 | 48PIN
AM29LV160DB | 16MBits | 27 | 16 | 50 | 83
TE28F320C3B | 32Mbits | 29 | 32 | 79 | 130
AT48BV8192A | 8Mbits | 5 | 8 | 28 | 41

串行EEPROM

24C02 2048bits / 0.1S 0.3S 0.4S 8-16PIN
AT24C256 256Kbits / 4.2S 8.2S 12.4S
AT24C512 512Kbits / 8.4S 13.5S 21.9S
25080 8192bits / 0.01S 0.1S 0.1S
25320 32Kbits / 0.1S 0.5S 0.6S
25LC1024 | 1Mbits | 0.2S | 1.5S | 3.9S | 4.6S
EN25T80 | 8Mbits | 8.4S | 12S | 18S | 38.4S
MX25L8005 | 8Mbits | 5.8S | 12S | 17S | 34.8S
MAX25L6405 | 64Mbits | 42S | 98S | 166S | 302S
95320 32Kbits / 0.1S 0.5S 0.6S
35080 8192bits / 0.1S 0.1S 0.2S
93C46 | 1024bits 　 　 　 | 0.1S
93CS56 | 2048bits | 0.1 | 0.1 | 0.4 | 0.6S
93C66 | 4096bits | 0.1 | 0.1 | 1.2 | 1.4S
93C86 | 8192bits | 0.1 | 0.1 | 2.4 | 2.6S

单片机编程时间列表：（ 单位：秒）

型号、容量 | 擦除 | 读C | 写C | 读E | 写E | 总T | 备注
AT89C51 4K 0.3 0.3 5.3 / / 5.9
AT89S52 8K 0.3 0.4 1.1 / / 1.8
AT89S8253 12K+2K | 0.3 | 0.7 | 3.7 | 0.1 | 0.7 | 5.5
AT89C4051 4K 0.2 0.2 6.4 / / 6.8 20P
SST89E58 32K+8K | 0.3 | 1.5 | 3.5 | 0.4 | 0.8 | 6.5
SST89E564 64K+8K | 0.3 | 3.0 | 7.0 | 0.4 | 0.8 | 11.5
ATMEGA8 8K+512 | 0.05 | 0.3 | 1.8 | 0.1 | 0.5 | 2.8
ATMEGA48 4K+256 | 0.05 | 0.1 | 0.9 | 0.1 | 0.1 | 1.25
ATMEGA162V 16K+512 | 0.1 | 0.6 | 2.5 | 0.1 | 0.4 | 3.7
ATMEGA8515 8K+512 | 0.1 | 0.3 | 1.8 | 0.1 | 0.5 | 2.8
ATTINY13 1K+64 | 0.02 | 0.1 | 0.7 | 0.01 | 0.04 | 0.9 | 8P
ATTINY2313 2K+128 | 0.01 | 0.1 | 0.7 | 0.02 | 0.04 | 0.9
PIC10F222 1K 0.2 0.1 1.0 / / 1.3
PIC12F629 2K+128 | 0.1 | 0.1 | 2.2 | 0.1 | 0.3 | 2.8
PIC16F873A 8K+128 | 0.1 | 0.5 | 4.5 | 0.1 | 0.8 | 6.0
PIC18F4550 32K+256 | 0.5 | 3.7 | 5.6 | 0.3 | 1.2 | 11.3
PIC18F67J10 128K bytes 0.5 16 20 / / 36.5
PIC16C712 2K / 0.1 0.9 / / 1.0
PIC16C74B 8K / 0.4 3.5 / / 3.9
GAL16V8 0.8 1.4 3.4 / / 5.6

注： <读C>指读或校验程序区的时间
<写C>指编程程序区的时间
<读E><写E>是指对片上数据区操作的时间
<总T>为总时间=<擦除>+<写C>+<读C>+<写E>+<读E>
单片机其他写配置位、加密位的时间没有在表中列出，但读写时间是极短的,大部分在100ms以下可以忽略不计。
总时间代表着可靠编程下的所有时间。

相关主题：

快速操作指南

完全操作指南
http://www.autoelectric.cn 中国 海南
TEL：0898 68681816 Mobile:13198907988 技术联系人：王鑫


迷你型 TL866 通用编程器-->应用软件的安装

◆支持的WINDOWS操作系统
 本编程器（软件V5.50版以上）支持微软最新的操作系统:
WINDOWS 2000 WINDOWS XP
WINDOWS 2003 WINDOWS 2008
WINDOWS VISTA WIN7(32bits and 64bits)
 在WIN7 64位操作系统安装时，必须以管理员身份运行EXE安装包.
软件安装时自动设别Windows操作系统版本号，进行快捷方便的自动安装。

 ◆程序安装步骤
1、从http://www.autoelectric.cn/minipro/index.htm 下载MiniPro_setup.exe文件，双击该文件进入安装程序界面。如下：（安装文件内包含了本说明书的内容） 点击[安装]开始安装应用程序，弹出如下画面：
注：在WIN7 64位操作系统安装时，以鼠标右键点击 MiniProVxxx_setup.exe文件，选择以管理员身份运行。
在这里输入你想安装的的目录。点击安装开始应用程序的安装。

2、安装进度是很快的，大概2秒种后完成应用程序的安装，接下来自动弹出安装驱动程序的对话框，如下：
一般情况不插入USB设备，点击[开始安装]按钮自动进行设备驱动程序的安装。

3、驱动安装，点击[下一步]

4、这一步，时间稍长

5、安装完成

◆下一步：进行设备安装
完成以上安装后，这时插入编程器到USB口，操作系统将发现硬件，如下：

选择[自动安装软件]，点击下一步，windows将自动安装，直到成功完成安装。
（注意：在这过程中，驱动程序会更改注册表，如果装了防火墙软件，请放行本软件，windows 还会提示驱动程序未经数字签证，确认后继续安装）。

完成安装后，已在[桌面]及[开始]--[程序]内添加了编程器应用程序的快捷方式图标，如下图：

可点击运行的桌面图标 开始--程序中的快捷方式

其中在[开始]--[程序]中的快揵方式：
MiniPro Programmer 可进入编程器应用程序。
MiniProHelp 为本程序的帮助文件。
Usb_Driver Install 为USB驱动设备安装程序，程序可手动安装驱动。
Uninstall 为反安装程序，可自动卸本软件安装的的所有驱动及文件

相关主题：


迷你型 TL866 通用编程器-->快速操作指南

◆硬件准备
 在您确保正确安装了通用编程器应用软件，以及USB驱动程序之后，连接好USB通讯线。此时编程器的红色电源指示灯亮指示连接正常(点亮状态)，黄色指示灯熄灭等待编程（如果黄色指示灯一值闪烁，表示USB驱动安装错误，或没有安装USB编程器设备驱动），编程器应用软件右下方显示硬件的版本号，即可进入下一步。

芯片放置方法：

◆选择被编程的芯片
 点击主菜单<芯片选择>或在用户界面内点击芯片选择按钮，选择你要编程的芯片型号，如下图：

注： 选择时注意芯片封装必须对上。部分芯片封装不同，引脚顺序可能不同。

◆装入缓冲区数据
 只有将所需要烧写到芯片的数据装载到数据缓冲区，才能执行编程操作。点击菜单工具栏中的“打开”按钮，弹出打开文件对话框，选择要打开的数据文件，弹出调入数据选择对话框。如下图：
1.选择要调入的文件

2.选择调入数据的方式,一般如果有多个缓冲区，指定缓冲区就可，其他的默认。
同样的方式调入所有数据到指定的缓冲区。
对与Microchip PIC单片机如果HEX文件附合MICROCHIP IDE环境则可一次调入到所有缓冲区，包刮配置信息。

◆设置芯片配置信息及加密选项

如果您需要对所编程芯片进行加密或其他配置操作，请选择缓冲区选择栏中的“CONFIG”按钮，弹出配置栏对话框。配置信息因芯片不同而不同。例如当所选芯片为AT89S8253时，将弹出如下图所示的对话框：

设定好配置信息及加密选项后，进入下一步。

◆编程设置：
 这一步一般情况按默认就可，如果需要芯片编号则选中芯片自动编号。
具体方法参考：<编程详解>-<设置芯片编号>

注意：
编程前擦除、查空、跳过写0xFF、编程前检查ID可跟据需要选择。
 校验后校验：虽然编程器绝大部分带有内部自校验，但仍然建议执行校验操作，以确保芯片烧录准确无误。

◆编程：点击工具栏上的"写"按钮弹出编程芯片对话框，如下：

A.编程缓冲区选择，默认为全部缓冲区。
B.正在操作的步骤提示区。
C.放大的芯片型号。
D.每步操作所耗时间提示。编程结束后可以看到每一步的编程时间。单位为MS.
E.进度条。

提示：上述步骤为烧写一片芯片的必须过程，根据不同芯片的操作步骤会有不同。

相关主题：

快速操作指南

完全操作指南
http://www.autoelectric.cn 中国 海南
TEL：0898 68681816 Mobile:13198907988
汽车电子技术网 Copyright @2009


迷你型 TL866 通用编程器-->用户界面

运行编程器用户程序后将出现如下用户界面:

  1. 主菜单：编程器应用软件的所有操作命令都可以在主菜单中找到并执行。
  2. 工具条：工具条上提供了打开，保存,编程器读、写、比较、查空、擦除等常用命令。
  3. 芯片选择快捷按钮。
  4. ID信息栏：按ID设别按钮时显示当前芯片的ID。
  5. 数据缓冲区：显示需要烧入芯片中的16进制数据，跟据芯片不同按8位或16位格式显示。
  6. 写芯片时的编程设置。
  7. 编辑缓冲区时，当前选定的地址 。
  8. 通信状态指示：当发现有USB设备时，显示设备的硬件固化程序版本号，当没有设备时显示"No Device"。
  9. 配置信息栏：显示当前被编程芯片所设置的配置信息,(芯片不同，该区域信息不同)。
  10. 数据缓冲区：显示需要烧入芯片中的ASCII码数据
  11. 缓冲区选择按钮，选择当前操作的缓冲区，如果芯片有多个缓冲区，将显示多个缓冲区的按钮
  12. 基本信息栏：提示当前所编程芯片基本信息，当工程模式时显示为工程信息
  13. 编程接口选择按钮。当不可用ICSP接口编程时，ICSP按钮变灰无效。
    N. 快速选取最近使用过的10个芯片。

详情参见：编程器功能详解

相关主题：

快速操作指南

完全操作指南

http://www.autoelectric.cn 中国 海南
TEL：0898 68681816 Mobile:13198907988
汽车电子技术网 Copyright @2009


迷你型 TL866 通用编程器-->编程器功能详解

本章节主要详细介绍MiniPro编程器编程器软件详细功能点以及具体操作。

菜单命令
◆文件菜单
打开、保存、缓存操作功能、退出
◆芯片选择菜单
按菜单列表选择被编程芯片
◆工程菜单
打开工程、保存工程、工程另存为、关闭工程、工程属性、工程密码更改
◆操作菜单
读取芯片内容、芯片ID设别、校验芯片、编程芯片、擦除芯片、查空、自动编号设定、测试
◆系统工具菜单
计算器、编程器升级检查、编程器自检
◆帮助菜单
帮助文件、关于
文件及缓存编辑功能详解
◆编辑缓冲区
在缓存中查找对应的16进制值或ASCII码字符串，数据，拷贝、复制、粘贴、填允、部分另存为TXT文件
编程器操作功能详解
◆选择芯片
按菜单列表选择被编程芯片。
◆读取芯片
读入芯片的有关内容到PC缓存。
◆编程芯片
把缓冲区的内容固化到芯片内。
◆擦除芯片
完全擦除芯片的内容（单片机部分芯片的时钟校正字节可跟据需要擦除，默认情况不擦除）。
◆查空芯片
检查芯片当前状态是否为未编程状态。
◆校验芯片
校检芯片与缓冲区的内容是否相同，可标记不同处校验。
◆设置芯片配置字
主要是设定单片机熔丝位，加密位等等。
◆设置芯片编号
多种格式的文件打开
◆编程器自检
检测编程器各个编程端口功能是否正常
◆ICSP编程
ICSP在线串行编程功能接口、及其使用方法
◆RAM测试
测试常见的静态RAM芯片
◆数字逻辑电路测试
测试54 74系列、CMOS4000/MC14xxx系列数字集成电路

相关主题：


MiniPro编程器-->菜单介绍-->文件菜单

◆文件菜单项目如下：

◆打开文件
 装入16进制文件或二进制文件到指定的缓冲区，GAL芯片时为装载JED格式的文件。

◆保存到文件
将当前缓存保存到16进制格式的HEX文件或2进制格式的BIN文件，GAL芯片时保存为JED格式文件。

注意:对于MICROCHIP的单片机，装入HEX文件时将可装入MiroChip IDE开发环境生成HEX文件到全部缓冲区，保存时可保存所有缓冲到HEX文件，并完全兼容MICROCHIP IDE开发环境。

◆复制、粘贴、块另存为、块定义、块填允、清空当前缓存、清空所有缓存
这些菜单功能可使用快捷键或右键菜单调出。
详见文件编辑功能--->编辑缓冲区

◆查找、查找下一个、地址定位
这些菜单功能可使用快捷键或右键菜单调出。
详见文件编辑功能--->编辑缓冲区

◆退出 退出MiniPro编程应用程序

相关主题：

快速操作指南

完全操作指南
http://www.autoelectric.cn 中国 海南
TEL：0898 68681816 Mobile:13198907988
汽车电子技术网 Copyright @2009


迷你型 TL866 通用编程器-->芯片选择

选择要被编程的芯片，在软件的左上角点击选择IC按钮。
弹出如下对画框：

选择时注意芯片封装必须对上。部分芯片封装不同，引脚顺序可能不同。

注：对同型号各种封装的IC如果没有在菜单中列出各种封装，对于非DIP封装的芯片则只要对照IC产品说明手册，直接连接对应引脚就可编程。

相关主题：


迷你型 TL866 通用编程器-->工程菜单

工程文件是为了更好的维护芯片的烧录而建立的概念。它是一个保存当前所有缓冲区数据及工作环境设置的文件，包括当前器件的信息，所有操作选项的设置，自动编号的有关设置。其方便日常量产使用。工程可设置密码保护，一定程度上可保护产品程序的安全。

◆工程菜单项目如下：

◆保存工程
 在应用程序中设置好烧录芯片的所需参数后,选择【工程】--【保存工程】,即建立了一个工程。并在窗口的信区显示工程信息。在【保存工程】点击后，输入工程名称并点击确定后弹出下面工程对话框：

1、密码可为空，则当前工程不设置密码保护。
2、工程如果设置为保护模式，密码必须输入。设为工程在保护模式后，工程的有关数据将不可更改。并且编程器有部分功能被禁用。

◆打开工程
 打开现存的工程,选择【工程】--【打开工程】,在打开窗口选择工程名称并点击确定。如果工程设置了密码，弹出以下对话框。（如果没有设置密码工程则直接打开）

◆工程另存为：
把当前工程，另存为另一个工程名。操作参考【保存工程】。

◆关闭当前工程
关闭打开的工程。切换到普通的编程模式，关清空当前的缓冲区数据。

◆工程属性
选择【工程】--【工程属性】,弹出属性设置对话框。

工程属性对话框可更更改工程描述及工程保护模式。保存时需输入工程密码。

◆更改工程密码
 重新设置工程密码

提示：
1、确切的工程描述可区分大量的工程。工程模式一般用与批量生产。
2、工程文件已经过一定的加密处理，保护好工程密码，可防止工程文件复制。一定程度上可保护数据。
3、工程文件保存或打开时都含32位CRC校验信息，可防止存储文件损坏等其他不确定因素。

相关主题：


迷你型 TL866 通用编程器-->操作菜单

本菜单功能是对芯片的编程操作。
◆操作菜单项目如下：

◆读芯片内容： 查看：<功能详解>--<读取芯片>

◆芯片ID识别： 本功能只是简单地读取芯片ID，在ID显示区显示信息。

◆数据校验： 查看：<功能详解>--<校验芯片>

◆芯片编程： 查看：<功能详解>--<编程芯片>

◆擦除芯片内容：查看：<功能详解>--<擦除芯片>

◆芯片查空： 查看：<功能详解>--<查空芯片>

◆自动编号设定： 查看：<功能详解>--<设置芯片编号>

◆测试： 查看：<功能详解>--<RAM_TTL_CMOS测试>

相关主题：


迷你型 TL866 通用编程器-->操作菜单

本菜单功能是对芯片的编程操作。
◆工具菜单项目如下：

◆计算器： 这是Windows自带的一个计算器，切换到科学型模式时对各种格式的计算很方便。

◆编程器自检： 对本编程器硬件进行自检操作。

点击后弹出如下对话框：

注意：编程器开始自检前，请移除40PIN插座上的IC及ICSP连接线，自检时编程器会向全部引脚施加VPP、VCC、GND进行测试，并进行内部短路过电流测试（同时在一个引脚上施加VPP VCC及GND），如果插入IC可能损坏插在上面的IC。测试完成后，在对话框内显示各个供电的测试情况。

◆固件FLASH刷新： 对编程器硬件固化程序进行刷新升级。

当升级新版本的应用程序后，如需要对FLASH内程序进行升级刷新，应用程序在进入时会提示进行固件刷新，如果不需要刷新，则此刷新功能禁用。点击<固件FLASH刷新>弹出如下对话框：

刷新时注意：关闭其他所有程序，并且保证计算机电源可靠！
点击<开始刷新>按钮进行刷新，刷新总时间大约30秒。点击<取消>可退出刷新。

相关主题：


迷你型 TL866 通用编程器-->帮助菜单

◆帮助菜单项目如下：

◆帮助： 按快捷键F1或点击本菜单内的<帮助>项可弹出本帮助文件

◆关于MiniPro： 本编程器有关信息,显示如下：

其中：<设备编号>及<序列号>是每个编程器唯一的代号 ,此序列号是一个随机生成的24位号码，存放于编程器硬件内，经加密处理。盗版者无法复制所有的序列号，跟据此序列号可在本公司查询设备的是否为正版产品。及产品质保时间。能更好地保障用户权益。

◆编程器在线升级： 打开本编程器产品网页，查看是否有升级版本。

相关主题：


迷你型 TL866 通用编程器-->编辑缓冲区

缓冲区块定义
缓冲区块填允
 复制、粘贴
块另存为
清空缓冲
查找、查找下一个
定位到地址
◆缓冲区块定义
块定义有两种方式：
 1、第一种方法是：在缓冲区内按信鼠标左键，移动鼠标，选择一块数据。图如下：

2、第二种方法是：在【主菜单】或鼠标【右键菜单】选择【块定义】，或直接按快捷键“CTRL+B”弹出如下对话框，输入开始地址及结束地址，按确定键就完成块定义。

对定义的数据块你可进行后续的块操作：块复制、块填允、块另存为TXT文件

◆缓冲区块填允

填充缓冲区是指，将程序代码缓冲区中某段连续地址的数据全部替换为一固定的值。
弹出鼠标【右键菜单】选择【块填允】，弹出如下对话框：

A、缓冲区选择栏，默认值为当前窗口显示的缓冲区。
B、要填允区块的开始地址和结束地址，默认值为：如定义了块，则为定义数据块的开始到结束。如果没有定义块，则为当前缓冲区的全区域大小。
C、填允值，最长允许4字节。如果填允方式为随机，则该值无关。
D、填允方式，默认方式：如果芯片按8位方式编程，则为默认单字节方式，如果芯片是按16位方式编程的则为双字节方式，你可随意改变你想要的填允方式。

◆复制
定义了数据块后，你可弹出鼠标【右键菜单】选择【复制】，这时块的内容已复制到WINDOWS的剪贴板内。
也可直接按CTRL+C键，完成复制。
 ◆粘贴
 功能：将复制到剪贴板的内容填允到缓冲区内。
操作：将光标移动到你要填允的缓冲区的开始地址后。按CTRL+V键。就完成粘贴。

将A区域的数据复制到B区域的效果

注意：为了加快粘贴的速度，剪贴板的数据格式为本编程器专用的二进制格式，所以其他WINDOW应用程序不能直接使用本程序复制到剪贴板的数据，如果要将数据块复制给其他的应用程序使用，请使用【块别另存为】TXT文件功能。

◆块另存为
 该功能把你定义的数据块输出为TXT文本文件，方便设计人员编程时应用，文本格式自动按16位或8位方式排列。
操作方法：定义缓冲区块后，点击鼠标右键，弹出右键菜单，选择【块另存为】。

◆清空当前缓冲： 功能：清空应用程序当前窗口显示的缓冲区。

◆清空所有缓冲： 功能：把芯片的所有缓冲区以默认值清空。

◆查找、查找下一个：
 功能：查找当前缓冲区中的HEX或ASCII码字符串。
操作：按CTRL+F或点击右前键菜单内的【查找】项，弹出如下对话框：

在输入框中输入要查找的HEX值或ASCII码字符串，最后点击对话框中的"查找"按钮。当在程序代码缓冲区中有与此匹配的十六进制数据或字符串时，光标将定位至第一个与所查找内容匹配的内容的地址，按F3键继续查找下一个。直至缓冲区全部搜索完毕。

◆定位到地址：
 功能：光标移动到当前缓冲区指定的地址。
操作：按快捷键CTRL+G，或按鼠标右键弹出菜单选择【地址定位】项后，弹出如下对话框：

输入地址，按确定按钮，光标将移动到地址处。

相关主题：


迷你型 TL866 通用编程器-->读取芯片

读取芯片是指将芯片中的数据读出至缓冲区中。不同芯片的读取窗口可能不同，下面以读取AT89S8253为例，说明如何读取芯片，点击工具栏中的【读】按钮，弹出下面对话框：

首先对【读取范围】进行设置,其中包括【CODE】【DATA】【FUSE】【LOCK】，开始地址及结束地址读取时无效。按【读取】按钮开始读芯片数据，注意：如果芯片被加密则读出值全为0xFF。
读取完成后，在信息栏内，显示各个缓冲的读取时间。

注意：读取操作一般不会报错,若想验证读取的数据是否正确,则使用校验功能验证,具体操作方法请查看校验说明，本编程器对芯片的操作前默认都会首先检查芯片的ID值。

相关主题：


迷你型 TL866 通用编程器-->编程芯片

编程芯片是指将缓冲区中的数据编程至芯片中。不同芯片的编程窗口可能不同，下面以编程AT89S8253为例，说明如何编程芯片。

1、首先将编程数据调入到缓冲区。

2、设置用户界面左下角的的编程设置，如下图：

3、点击工具栏中的【写】按钮，弹出下面对话框：

首先对【编程范围】进行设置,其中包括【CODE】【DATA】【FUSE】【LOCK】。按【编程】按钮开始编程芯片。

提示：
◆编程完成后，在信息栏内，显示各个缓冲的编程时间。
◆大部分芯片，本编程器在编程过程中进行自动校验，如果编程过程中发现错误会立刻终止编程。
◆如果用户选择了"芯片编号自增"选项，则在芯片编程完后，缓冲区中的芯片编号将按照设定自动增加。
◆为了保证编程数据的正确，对于编程后校验，建议用户总是执行。

相关主题：


迷你型 TL866 通用编程器-->擦除芯片

对可电擦除的芯片点击工具栏中的【擦除】按钮，弹出下面对话框：

默认情况擦除前检查芯片ID，对很少部分单片机，有的芯片加密后不可读取芯片ID，这时应在主界面中取消ID检查，否则ID检查错误。点击对话框中的【 擦除】按钮，擦除完成后，显示擦除的时间。

相关主题：


迷你型 TL866 通用编程器-->芯片查空

点击工具栏中的【查空】按钮，弹出下面对话框：

默认情况擦除前检查芯片ID，查空前可先选择芯片要查空的区域，默认为全部。点击对话框中的【 查空】按钮，开始查空操作后，完成显示查空各个区域所化的时间。如果查空其间，发现芯片非空，则终止查空，并显示非空区域的地址及存储值。

相关主题：


迷你型 TL866 通用编程器-->校验芯片

点击工具栏中的【校验】按钮，弹出下面对话框：

默认情况擦除前检查芯片ID，校验前可先选择芯片要校验的区域，默认为全部。点击对话框中的【 校验】按钮，开始校验操作后，如查全部数据相同，完成后显示校验各个区域所化的时间。如上图所示。
如果校验期间，发现芯片数据不同，则弹出如下对话框：

点击【继续比较】： 将继续比较如又有不同则又会弹出同样的对话框提示。
点击【 标记不同处】：将比较完芯片的全部内容，在比较过程中如发现不同也不会弹出提示，直到完成后，提示有多少处不同，并在缓冲区内以红色字体显示不同的单元，如下图所示。
点击【退出】：将直接退出，不进行后面的比较。

相关主题：


迷你型 TL866 通用编程器-->配置芯片

点击芯片缓冲区选择栏中的【CONFIG】按钮，弹出下面界面(芯片型号PIC18F4550)：

右下角芯片配置信息的内容的值与配置界面对应：点击配置界面，配置信息内的值自动改变。

1、不同芯片的配置信息不同，所以用户首先查看芯片的数据手册,并安装具体的需要来正确的配置芯片。
2、各个芯片配置界面，都经精心设计，可以使用户可很直观地查看比较芯片的说明手册。
3、有些芯片无配置信息。
4、下面列了常见的一些配置界面：

◆PIC18FXXX界面如上图，ID内容在主画面内编辑，型号不同，表内的内容不同。
图：同上
◆PIC10xxx 12xxx 16xxx配置图一般如下，芯片不同有的内容有不同。

PIC有部分芯片擦除时要注意，芯片的复位向量（ResetVector）,默认情况本编程器不会擦除芯片的复位向量，当如果你在配置界面对校正字节（同复位向量）进行编程，则擦除时将擦除该复位向量。如果该芯片没有备份的校正值，你又把校正字节搞错了，如果你使用内部时钟，则可能会有时钟偏差，引起该芯片无法使用。
注：正常情况下没有必要对校正字节进行更改，出厂已校正

◆ATMEGA配置图一般如下，芯片不同有的内容有不同。

◆其他更多的界面，请在应用程序内试验理解,想信你一定会觉得很好用。

相关主题：


迷你型 TL866 通用编程器-->芯片编号设定

芯片编号设定功能是，在编程时给芯片自动加入一个编号到芯片某个存储区域内，可方便用于芯片出厂时的设置编程。加入时间或唯一序列号等等，本编程器有多种编号算法可供使用，能附合各种用户的要求。

点击<主菜单>---<操作>---<自动编号设定>可弹出如下对话框：

首先选择自动编号算法，在对话框内有四种算法可供选择，下面对各种编号算法的作分别说明.

1、默认增量算法
该算法的设置界面就是上图所示，该算法功能是在设定的存储区域开始地址的地方，放入一个设定的长度的编号，编号每次按步长增加。设定好参数后，你可按<测试>按钮进行测试，查看各种参数设定下的变化规律。
编码的初值及步长等可在对话框内设定。
设定好参数并测试正确无误后，设定记录文件，如果为空则记录文件无效，编程时不会把数据记录到文件中，如果设定了记录文件，则每次编程后，都把你设置的编号添加到记录文件的最后。

最后，选中<允许自动编号>按钮，并<保存设置>。

2、时间算法
时间算法对话框界面如下图：

时间编码格式有四种，分别是：
（1）日期+时间 编号总长：16字节
编程时在指定的位置添加日期及时间，总长是16bytes.
（2）日期+5个字节的增量 编号总长：16字节
其中增量部分内容可设定初值及步长。
（3）日期+时间+8个字节的增量 编号总长：24字节
其中增量部分内容可设定初值及步长。
（4）日期+时间+16字节随机编号 编号总长：32字节
其中16字节是随机产生的字节，可生成产品的唯一序列号。这种方式下，记录文件必须设置，让产生的编码记录在文件中。否则你自已也不知道产品的编号是什么。

后面的操件步骤同上《默认增量算法》

3、随机序列号算法
 该算法产生一个指定长度的随机号，如下图：

4、用户自定义算法
用户自定义算法有很强的灵活性，你可以设定任意的编号算法，详细的使用方法请看目录..\\Serialnumber\source_dll的中VC++源程序中的注释说明。界面如下：

AVR单片机的RC校正字节加密方法，完全利用此地调用DLL动态库实现，
..\\TAMEGA_LED目录内含所有源程序及测试方法。

制作好DLL文件后，你只要把它复制到应用程序目录下的..\\Serialnumber的子目录中，就可。设置时就在用户算法文件列表中，选择你制作的算法文件。
后面的操件步骤同其他算法。

------------重要提示：-------------------------------------
1、设置好以上内容后，编程器时在编程操作时，并不会自动添加你设定的编号到芯片中，要自动添加编号你还必须在主界面中选中<芯片编号自增>。
2、主界面中能选中<芯片编号自增>的条件是，必须首选设置好编号算法，并在算法内设定<允许自编号>。
3、在主界面中选中<芯片编号自增>后，如果你又重新设定编号算法，则主界面中<芯片编号自增>按钮必须重新选中。
4、编程芯片型号变换后，必须重新设定编号设定算法。
5、在工程模式下，该算法保存在工程文件中，可直接打开工程文件，并自动调入自动编号算法。所以批量生产时一般在工程模式下使用，简单方便。

相关主题：


迷你型 TL866 通用编程器-->ICSP编程

对可串行在线编程的芯片，本编程器可通过独特的ICSP接口对目标板上的单片机进行编程，编程前先在主界面的编程口选择栏，选择ICSP口，些时【ICSP_VCC_ENABLE】变为允许状态，默认【ICSP_VCC_ENABLE】选中， 表示编程向目标板提供VCC电源。（注意，编程器VCC电源最大能提供的电流为120ma,如果目标板需要更大的电源，请用目标板自供电源。最好的方法是把CPU供电跟板上其他大电流元器件隔离，这样使用编程器电源供电，编程更方便）
如果不需要编程器提供电源，可不选中【ICSP_VCC_ENABLE】按钮，这样编程时的VCC引脚上将没有VCC电源。如下图所示：

这样下一步操作，读取、擦除、校验、编程等操作时，将从ICSP口进行操作，操作时40PIN万能座上不可同时插入芯片，点击工具栏上的【写】按钮，弹出如下对话框：（注意读取、擦除、校验等操作的对话框和这个写操作一样，多了一个ICSP提示项）。

点击【查看ICSP接线法】按钮可弹出当前芯片的串行编程接法，接线法如下图：

（芯片不同ICP连接法不同）

注：
1、ICSP现支持ATMEL89S51、52 AT45DBxxx AVR ATMEGAxxx全系列及MICROCHIP PIC10Fxxx 12Fxxx 16Fxxx 18Fxxx、SM59Dxx SM59Rxx芯片进行在线串行编程。将来会增加其他更多支持串行在线编程的单片机。
2、一般情况下，40PIN插座编程是快速的并行编程，ICSP是的对目标板串行在线编程。
3、对PIC10 12 16 系列芯片的编程，40PIN及ICSP口，都是进行高压的串行编程,18系列跟据芯片不同，VPP电压有区别。但ICSP口及40PIN座的编程方法是一样的 ，编程速率 ICSP口比40PIN座编程稍慢一点。。
4、ATMEL的AT89Sxx ATMEGAxxx,SPI编程速度与并行编程相比，速度相差很多，本编程器的并行编程速度是最优秀的一个，完全可附合批量生产的需要。
5、TL866CS型号的编程器。限止了ICSP接口的编程功能。

相关主题：


迷你型 TL866 通用编程器-->RAM测试

选择对应型号的RAM芯片后，点击工具栏中的【测试】按钮，弹出下面对话框：

RAM测试有4种方法，通过这四种方法的测试，基本上可测试RAM的单元功能是否正常。
一般编程器只对RAM单元读写是不可测试出RAM的好坏的。例如：如果两条相临的地址线短路，你只是向RAM单元简单地读写数据，是不可能检查出问题的。所以只是有一种方法测试是不完整的测试。

插入芯片，点击【测试】按钮，可进行RAM的测试。

相关主题：


迷你型 TL866 通用编程器-->数字电路测试

本编程器可能是第一个真真可以测试常用74系列 CMOS4000系列集成电路的第一台开发型综合功能的编程器，测试时可以定位到某个门电路的故障。
选择对应型号的数字逻辑集成芯片后，点击工具栏中的【测试】按钮，弹出下面对话框：

以上是对74HC00的测试结果，正常情况下显示各个逻辑单元测试是否正常，信息框内显示经多种输入组合测试。如果集成电路某个门电路错误，例把74HC00的PIN1弯曲断开，测试结果显示如下：提示芯片错误。

根据芯片不同，逻辑单元个数不同。逻辑单元编号同集成电路手册。

相关主题：


迷你型 TL866 通用编程器-->AVR单片机软件加密

AVR单片机有一个RC Calibration(校正字节)，这个字节值几十个芯片才有一个可能相同，并且无法修改。单片机软件可读出该值，判断这个值就可确定该代码是否被使用到另一个芯片上，通过自定义的加密算法可使暴力破解者无法直接使用。 如果加密算法足够复杂，想信要破解也不是容易的了。但“加密”对开发人员提出了一个问题，每个芯片不同，如果算法复杂不可能一个个去人工计算分别编译原代码。本编程器能在编程前自动读入RC字节，开发人员可在DLL动态函数中得到芯片该字节的值，然后跟据该值按你的要求自动计算加密数据放入存储器中，完成快速量产。

安装包中 目录\\ATMEGA8_LED中有个关于ATMEGA8详细加密实例，可供参考。

操作方法基等同自定义编号算法，查看 [image] 设置芯片编号

实例的内容是通过加密算法编程的芯片可以正常运行，而从芯片中复制出来的程序放到另一个芯片上则运行错误，本编程器的功能是实现芯片快速加密量产。

相关主题：


迷你型 TL866 通用编程器-->如何新增器件

芯片生产厂商的产品和技术在不断的更新。为了使您和我们的产品能够做的更好，如果您在编程器的器件列表中找不到您想编程的芯片,请立刻与我们技术支持部联系。我们会在硬件驱动能力允许,芯片和编程资料齐全的情况下,可能请你提供1-2片样片，会尽快增加对该器件的支持。 联系电话：0898 68681816 MOBILE：13198907988 联系人：王鑫。电子邮件:autoelector@yahoo.com。

请您仔细填写以下信息,并以电子邮件的方式发送给我们.

联系方式：
1、姓名：
2、公司名称：
3、联系电话：
4、EMAIL：

编程器信息：
1、型号：TL866
2、购买日期： 年 月 日
3、编程器编号： （8位，在软件<关于>菜单中）

需新增芯片的具体信息：
1、芯片厂商：
2、芯片详细型号：
3、芯片封装类型：

相关主题：


迷你型 TL866 通用编程器-->产品保修

◆保修服务

在正常使用范围内，从购买产品之日起一年内，若产品出现故障可免费保修。

◆免责条款
A、未经我们正式授权的任何组织或个人修理、操作或改动过的产品，不在包修责任内。
B、产品中锁紧座及其它人为的损坏，不在包修责任内。
C、因为硬件故障或软件缺陷造成的连带扩展责任。

◆特别申明

由于编程器，支持的芯片种类多，软件系统复杂，错误或缺陷是难免的。在批量生产时，特别时对OTP一次性编程芯片，你必须确认编程正确无误后，才能进行批量生产。本公司不对因为硬件故障或软件缺陷造成的连带扩展损失负责。如发现问题或对我们的产品有好的宝贵意见，请联系我们。

◆其他事项：

 随着软件更新，本说明书内容仅供参考， 以产品应用软件为准。
你可在 http://www.autoelectric.cn/minipro/index.htm 下载最新的应用软件。

名称：海口鑫工电子有限公司
地址：海南省海口市南海大道西一号 邮编：570311
EMIAL：autoelector@yahoo.com
TEL:0898-68681816 FAX:0898-68681815

相关主题：

快速操作指南

完全操作指南
http://www.autoelectric.cn 中国 海南
TEL：0898 68681816 Mobile:13198907988 技术联系人：王鑫


MiniPro编程器-->芯片支持范围

建设中..........

相关主题：